BLENDER TRIBU
Vous souhaitez réagir à ce message ? Créez un compte en quelques clics ou connectez-vous pour continuer.
Le Deal du moment : -32%
-32% Gigabyte G5 MF – PC portable 15,6″ ...
Voir le deal
749.99 €

Aller en bas
avatar
blendinfos

Résolu Pas d'éclairage sur un objet ?

Mer 6 Déc - 19:05
Bonjour,

J'ai importé dans Blender un .obj et malgré la présence d'un "point" il ne s'éclaire pas (copie d'écran ci-dessous).
https://www.zupimages.net/up/23/49/xwba.jpg
J'ai mis un objet à côté pour voir que ce n'est pas un problème d'éclairage mais de l'objet. Ce qu'on voit aussi sur cette copie d'écran est bizarre car par transparence l'objet semble éclairé à l'intérieur quand on regarde à l'opposé du "point".

Je l'ai mis dans un viewer en ligne. On observe qu'il n'est pas éclairé non plus et qu'on voit par transparence d'autres parties de l'objet (copie d'écran ci-dessous).
https://www.zupimages.net/up/23/49/cfra.jpg

Ci-dessous une copie d'écran du shade editor :
https://www.zupimages.net/up/23/49/zdr8.jpg

J'ai vérifié que le sens des normales étaient vers l'extérieur, et l'analyse 3D print ne montre aucun défaut sur l'objet.

Auriez-vous une explication à ce problème ?

Merci d'avance pour vos réponses.


Dernière édition par blendinfos le Mer 6 Déc - 19:53, édité 2 fois
Blender Moonboots
Blender Moonboots

Résolu Re: Pas d'éclairage sur un objet ?

Mer 6 Déc - 19:20
Bonsoir Blendinfos, peux-tu partager ton fichier ? (en MP si tu ne veux pas que ce soit public)

_________________
Ma chaîne de tutos sur Youtube
avatar
blendinfos

Résolu Re: Pas d'éclairage sur un objet ?

Mer 6 Déc - 19:33
C'est bon ça fonctionne.
C'est en modifiant le shader editor par hasard que je me suis aperçu que c'était la transmission qui était sûrement à l'origine du problème (à 1 dans la copie d'écran ci-dessus).
Du coup ayant mis une copie d'écran du shader editor avant j'ai pu comparer que c'était lié à ça je pense.
Merci tout de même pour votre retour.


Dernière édition par blendinfos le Mer 6 Déc - 19:39, édité 1 fois
Blender Moonboots
Blender Moonboots

Résolu Re: Pas d'éclairage sur un objet ?

Mer 6 Déc - 19:34
difficile à dire, j'ai l'impression qu'il y a des petits bugs sur la version 4 mais je n'en suis pas sûr

_________________
Ma chaîne de tutos sur Youtube
avatar
blendinfos

Résolu Re: Pas d'éclairage sur un objet ?

Mer 6 Déc - 19:44
soit c'était un bug
soit je ne comprends pas pourquoi la transmission était une fois à 1 puis 0 sans que je fasse de modification manuellement
Contenu sponsorisé

Résolu Re: Pas d'éclairage sur un objet ?

Revenir en haut
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum